思科路由器配置(思科路由器拨号上网简单配置)-科科网络

图中路由器R1为出口路由器通过拨号连接外网,下来简单了解下如何通过它让客户端获取到ip地址并且能上外网:

首先用超终端或CRT进入思科路由器配置模式,然后进行配置

ip dhcp excluded-address 192.168.10.6192.168.10.254(dhcp中被保留不被下放的ip地址)

ip dhcp pool abc(dhcp池的名字起为abc这个可以随意填写)

network 192.168.10.0 255.255.255.0(dhcp下放的网段为192.1.10.x)

default-router 192.168.10.254(网关的设置)

dns-server 218.30.19.40 61.134.1.4(dns的设置)

vpdn enable(启用vpdn服务)

interface Dialer1(创建虚拟拨号接口1)

ipaddress negotiated(ip地址自动协商)

ipmtu 1492(因为ppp占8个字节所以为1492)

ipnat outside(启用nat转换服务并设置为外部接口)

encapsulation ppp(封装ppp协议)

dialer pool 1(为拨号池1)

pppauthentication pap callin(设置ppp的认证方式)

ppp chap hostname xxxxx(宽带账号)

pppchap password a123456(宽带密码)

ppppap sent-username xxxxx password 123456

 

interface FastEthernet0/0

no ipaddress

duplex auto

speedauto

pppoe-client dial-pool-number 1(将该端口加入到拨号池1中)

Interface FastEthernet0/1

ip address 192.168.10.254 255.255.255.0

ip nat inside (启用nat服务 并为内部接口)

 

ip route 0.0.0.0 0.0.0.0 Dialer1(设置默认路由让走拨号端出去)

 

ip nat inside source list 1 interfaceDialer1 overload(使用nat转换将acl1中的地址用dialer1获取的公网地址转换)

 

access-list 1 permit 192.168.10.0 0.0.0.255(允许上网的网段)

实在不明白的可以将以上命令按需求配置好后,粘贴到配置页面!